Welcome to the Australian Ford Forums forum.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and inserts advertising. By joining our free community you will have access to post topics, communicate privately with other members, respond to polls, upload content and access many other special features without post based advertising banners. Registration is simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us.

Please Note: All new registrations go through a manual approval queue to keep spammers out. This is checked twice each day so there will be a delay before your registration is activated.

Go Back   Australian Ford Forums > Ford Australia Vehicles > Small and Mid Sized Cars > Cougar and Probe

Reply
 
Thread Tools Display Modes
Old 26-08-2022, 03:06 AM   #1
V6cougar2.5
Starter Motor
 
Join Date: Feb 2022
Posts: 2
Lightbulb HVAC control panel not works (Cougar & Mondeo)

Hello everybody !

the HVAC control panel of my Cougar does not works (is the LCD european style, see picture below). This HVAC control panel was also equipped in the Mondeo mk1 and mk2.

The last weeks, the HVAC control panel worked perfectly in the mornings (cold exterior temperature), but in the afternoons after several hours under the sun, the HVAC control panel does not worked.

Finally this week, the HVAC control panel does not works anymore.


When I turn the knobs and press the buttons, it does nothing:
- the LCD screen show nothing.
- the illumination of the LCD screen is always off (even if I turn on the headlights).
- the blower does nothing.
- the AC clutch compressor not activates.


I have checked (including a wiggle test) all the fuses of the two fusebox (specially the fuses number 23, 34 and 37 related to heater blower and AC system) and is all Ok.

I have checked also the blue color relay R3 (related to AC) and replaced it with a new one. The relay works ok (activates when I turn on ignition switch) but in becomes very hot after 5 minutes of turn the key of the start switch.

I have do a wiggle test of the rear connectors and cables of the HVAC control panel, but still not works.

I have replaced the HVAC control with another used one, and still not works.


Please, has anyone had the same problem?
Any help will be appreciated.

Thanks in advance and sorry for my bad English.



My car is a 1998 Ford Cougar 2.5 manual transmission.
This is my HVAC control panel:

V6cougar2.5 is offline   Reply With Quote Multi-Quote with this Post
Old 19-12-2022, 07:19 AM   #2
V6cougar2.5
Starter Motor
 
Join Date: Feb 2022
Posts: 2
Default Re: HVAC control panel not works (Cougar & Mondeo)

SOLVED !!!

I found the problem doing a wiggle test to the cables under the dashboard.

The problem was a cable connector in the Fuse box under the steering wheel.

The connector is named C371 in the Ford TIS wiring diagram.











In the following pictures you can see a pin open and the connector melted.







This have cuased poor electrical contact and finally the pin open and no power to the HVAC Climate control panel.

As I have read in other forums, this is common fault in the Cougar and the Contour (Mondeo), and most cars have this connector melted.
You can read about this same problem in this Contour forum:
https://www.contour.org/forums/thre....-blower.53810/


Luckly this connector is still available new.

I bought a new connector, replaced and the Climate control works again.

You can found this connector searching the following words in eBay or Aliexpress:
"Heater Blower Fan Resistor Wiring Harness Connector Ford"

Here some links to buy it:
https://www.parlakoto.com/en/catalog.../view/id/10135

https://onecarpart.co.uk/p/17082/par...-pin-connector

https://es.aliexpress.com/item/1005001779884938.html

https://es.aliexpress.com/item/32914832426.html

https://es.aliexpress.com/item/1005001779925847.html

This are the part numbers of the connector I have found:
MOTORCRAFT: WPT-480
STANDARD MOTOR: S-719
FORD OE: 977632
ACDELCO: 88860548 / PT1993
ACDELCO PROFESSIONAL: PT1993
ACDELCO PROFESSIONAL CANADA: PT1993
AIRTEX AUTOMOTIVE DIVISION: 1P1403 / 1P1408
AIRTEX ENG. MGMT. SYSTEMS: 1P1247 / 1P1403
AUTOZONE/AEM: 1P1247
AUTOZONE/DURALAST-WELLS: 615 / 771
AUTOZONE/MOTORCRAFT: WPT-480 / WPT480
CARQUEST: 57-4694 / 57-5182 / 57-5187 / 574694 / 575182 / 575187
CARQUEST/STANDARD MOTOR PRODS.: 574694 / S719
CARQUEST/WELLS: 575182
DORMAN: 973-303 / 973303
DORMAN - TECHOICE: 973-303 / 973303
KEMPARTS: 350363
NAPA: EC158
NAPA/ECHLIN PARTS-ECH: EC158
NIEHOFF: PS37501
WELLS: 57-4694 / 574694 / 771 / 776





I hope this can help to someone.
Best regards.

Last edited by V6cougar2.5; 19-12-2022 at 07:34 AM.
V6cougar2.5 is offline   Reply With Quote Multi-Quote with this Post
This user likes this post:
Reply

Thread Tools
Display Modes

Forum Jump


All times are GMT +11. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Other than what is legally copyrighted by the respective owners, this site is copyright www.fordforums.com.au
Positive SSL